package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-CEGHJ-PR-TW-Z]{2}[0-9]{6}[A-DFM]{1}$`)
var str = `QQ123456C
AA123456C
KM673437D
AQ123456C
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}