$re = '/^[A-CEGHJ-PR-TW-Z]{2}[0-9]{6}[A-DFM]{1}$/m';
$str = 'QQ123456C
AA123456C
KM673437D
AQ123456C
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);