import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-CEGHJ-PR-TW-Z]{2}[0-9]{6}[A-DFM]{1}$";
final String string = "QQ123456C\n"
+ "AA123456C\n"
+ "KM673437D\n"
+ "AQ123456C\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}