re = /^[A-CEGHJ-PR-TW-Z]{2}[0-9]{6}[A-DFM]{1}$/m
str = 'QQ123456C
AA123456C
KM673437D
AQ123456C
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end