import re
regex = re.compile(r"^[A-CEGHJ-PR-TW-Z]{2}[0-9]{6}[A-DFM]{1}$", flags=re.MULTILINE)
test_str = ("QQ123456C\n"
"AA123456C\n"
"KM673437D\n"
"AQ123456C\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")