#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<img[ .=":;a-zA-Z0-9]+(height:[ 0-9]+px)+"
Local $sString = "<div style="height: 300px"><img src="t.jpg" style="width:1000px; height: 300px"><img src="t.jpg" style="width:1000px; height: 500px"><eee src="t.jpg" style="width:1000px; height: 500px">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")