const regex = /<img[ .=":;a-zA-Z0-9]+(height:[ 0-9]+px)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img[ .=":;a-zA-Z0-9]+(height:[ 0-9]+px)+', 'g')
const str = `<div style="height: 300px"><img src="t.jpg" style="width:1000px; height: 300px"><img src="t.jpg" style="width:1000px; height: 500px"><eee src="t.jpg" style="width:1000px; height: 500px">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}