package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img[ .=":;a-zA-Z0-9]+(height:[ 0-9]+px)+`)
var str = `<div style="height: 300px"><img src="t.jpg" style="width:1000px; height: 300px"><img src="t.jpg" style="width:1000px; height: 500px"><eee src="t.jpg" style="width:1000px; height: 500px">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}