$re = '/<img[ .=":;a-zA-Z0-9]+(height:[ 0-9]+px)+/';
$str = '<div style="height: 300px"><img src="t.jpg" style="width:1000px; height: 300px"><img src="t.jpg" style="width:1000px; height: 500px"><eee src="t.jpg" style="width:1000px; height: 500px">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);