import re
regex = re.compile(r"<img[ .=\":;a-zA-Z0-9]+(height:[ 0-9]+px)+")
test_str = "<div style=\"height: 300px\"><img src=\"t.jpg\" style=\"width:1000px; height: 300px\"><img src=\"t.jpg\" style=\"width:1000px; height: 500px\"><eee src=\"t.jpg\" style=\"width:1000px; height: 500px\">"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")