#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(19[0-9][0-9]|20[012][0-9])$"
Local $sString = "1980" & @CRLF & _
"2005" & @CRLF & _
"2015" & @CRLF & _
"2029" & @CRLF & _
"2030" & @CRLF & _
"1853" & @CRLF & _
"1900" & @CRLF & _
"1959" & @CRLF & _
"14" & @CRLF & _
"2017" & @CRLF & _
"2000" & @CRLF & _
"2030" & @CRLF & _
"2029" & @CRLF & _
"1960" & @CRLF & _
"1899" & @CRLF & _
"2000" & @CRLF & _
"1999" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")