import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(19[0-9][0-9]|20[012][0-9])$";
final String string = "1980\n"
+ "2005\n"
+ "2015\n"
+ "2029\n"
+ "2030\n"
+ "1853\n"
+ "1900\n"
+ "1959\n"
+ "14\n"
+ "2017\n"
+ "2000\n"
+ "2030\n"
+ "2029\n"
+ "1960\n"
+ "1899\n"
+ "2000\n"
+ "1999\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}