$re = '/^(19[0-9][0-9]|20[012][0-9])$/m';
$str = '1980
2005
2015
2029
2030
1853
1900
1959
14
2017
2000
2030
2029
1960
1899
2000
1999
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);