// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(19[0-9][0-9]|20[012][0-9])$").unwrap();
let string = "1980
2005
2015
2029
2030
1853
1900
1959
14
2017
2000
2030
2029
1960
1899
2000
1999
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}