using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(19[0-9][0-9]|20[012][0-9])$";
string input = @"1980
2005
2015
2029
2030
1853
1900
1959
14
2017
2000
2030
2029
1960
1899
2000
1999
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}