#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$Id\: (\S+?) ([vx.0-9a-f]+)\b (\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}Z \S+?) \$"
Local $sString = "# $Id: svnref.pm 22354 2022-03-12 17:55:30Z author $" & @CRLF & _
"# $Id: semver.pm 1.2.1 2022-03-12 17:55:30Z author $" & @CRLF & _
"# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $" & @CRLF & _
"# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $" & @CRLF & _
"# $Id: gitcommit.pm 42e2e5a 2022-03-12 17:55:30Z author $" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")