# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\$Id\: (\S+?) ([vx.0-9a-f]+)\b (\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}Z \S+?) \$"
test_str = ("# $Id: svnref.pm 22354 2022-03-12 17:55:30Z author $\n"
"# $Id: semver.pm 1.2.1 2022-03-12 17:55:30Z author $\n"
"# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $\n"
"# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $\n"
"# $Id: gitcommit.pm 42e2e5a 2022-03-12 17:55:30Z author $\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.