use strict;
my $str = '# $Id: svnref.pm 22354 2022-03-12 17:55:30Z author $
# $Id: semver.pm 1.2.1 2022-03-12 17:55:30Z author $
# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $
# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $
# $Id: gitcommit.pm 42e2e5a 2022-03-12 17:55:30Z author $
';
my $regex = qr/\$Id\: (\S+?) ([vx.0-9a-f]+)\b (\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}Z \S+?) \$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}