using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$Id\: (\S+?) ([vx.0-9a-f]+)\b (\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}Z \S+?) \$";
string input = @"# $Id: svnref.pm 22354 2022-03-12 17:55:30Z author $
# $Id: semver.pm 1.2.1 2022-03-12 17:55:30Z author $
# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $
# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $
# $Id: gitcommit.pm 42e2e5a 2022-03-12 17:55:30Z author $
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}