import Foundation
let pattern = #"\$Id\: (\S+?) ([vx.0-9a-f]+)\b (\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}Z \S+?) \$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
# $Id: svnref.pm 22354 2022-03-12 17:55:30Z author $
# $Id: semver.pm 1.2.1 2022-03-12 17:55:30Z author $
# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $
# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $
# $Id: gitcommit.pm 42e2e5a 2022-03-12 17:55:30Z author $
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)