// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$Id\: (\S+?) ([vx.0-9a-f]+)\b (\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}Z \S+?) \$").unwrap();
let string = "# $Id: svnref.pm 22354 2022-03-12 17:55:30Z author $
# $Id: semver.pm 1.2.1 2022-03-12 17:55:30Z author $
# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $
# $Id: sewver.pm v1.2 2022-03-12 17:55:30Z author $
# $Id: gitcommit.pm 42e2e5a 2022-03-12 17:55:30Z author $
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}