# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/myArray(\[.+?])(\[.+?]\[.+?])(\[.+?])/myArray$3$2$1/gm;t' <<< "myArray[a][...][...][b]"