#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)myArray(\[.+?])(\[.+?]\[.+?])(\[.+?])"
Local $sString = "myArray[a][...][...][b]"
Local $sSubst = "myArray$3$2$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)