use strict;
my $str = 'myArray[a][...][...][b]';
my $regex = qr/myArray(\[.+?])(\[.+?]\[.+?])(\[.+?])/mp;
my $subst = 'myArray$3$2$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";