import Foundation
let pattern = #"myArray(\[.+?])(\[.+?]\[.+?])(\[.+?])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"myArray[a][...][...][b]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"myArray$3$2$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)