package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)myArray(\[.+?])(\[.+?]\[.+?])(\[.+?])`)
var str = `myArray[a][...][...][b]`
var substitution = "myArray$3$2$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}