# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=(\d{2}$)+(?!\d))//gm;t' <<< "11,11
00,00
20,20
20.20
30.233
1000000000000000
123123
12432"