re = /(?=(\d{2}$)+(?!\d))/m
str = '11,11
00,00
20,20
20.20
30.233
1000000000000000
123123
12432'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result