import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(\\d{2}$)+(?!\\d))";
final String string = "11,11\n"
+ "00,00\n"
+ "20,20\n"
+ "20.20\n"
+ "30.233\n"
+ "1000000000000000\n"
+ "123123\n"
+ "12432";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}