using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{2,6}$)([a-z]+[0-9]*)$";
string input = @"a1
abc12
ab123
abcd1
abcd
abcde
abcdef
abcdefg
abcde1
abcde12
#aaaa
a#2
a
1abc
123456
ab23c
a1b2c1
a12345
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}