import re
regex = re.compile(r"^(?=.{2,6}$)([a-z]+[0-9]*)$", flags=re.MULTILINE)
test_str = ("a1\n"
"abc12\n"
"ab123\n"
"abcd1\n"
"abcd\n"
"abcde\n"
"abcdef\n"
"abcdefg\n"
"abcde1\n"
"abcde12\n\n"
"#aaaa\n"
"a#2\n"
"a\n\n"
"1abc\n"
"123456\n"
"ab23c\n\n"
"a1b2c1\n"
"a12345\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")