re = /^(?=.{2,6}$)([a-z]+[0-9]*)$/m
str = 'a1
abc12
ab123
abcd1
abcd
abcde
abcdef
abcdefg
abcde1
abcde12
#aaaa
a#2
a
1abc
123456
ab23c
a1b2c1
a12345
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end