use strict;
my $str = 'a1
abc12
ab123
abcd1
abcd
abcde
abcdef
abcdefg
abcde1
abcde12
#aaaa
a#2
a
1abc
123456
ab23c
a1b2c1
a12345
';
my $regex = qr/^(?=.{2,6}$)([a-z]+[0-9]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}