#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)http\S*?(?:accounts?+|tech|customers?+|supports?+|services?+|phones?+|helps?+)[\w-]{0,10}(?:services?+|cares?+|helps?+|recover(?:y|ies)?+|supports?+|phones?+|numbers?+)"
Local $sString = "<a href="https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers" rel="nofollow noreferrer">https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers</a></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")