// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)http\S*?(?:accounts?+|tech|customers?+|supports?+|services?+|phones?+|helps?+)[\w-]{0,10}(?:services?+|cares?+|helps?+|recover(?:y|ies)?+|supports?+|phones?+|numbers?+)").unwrap();
let string = "<a href=\"https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers\" rel=\"nofollow noreferrer\">https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers</a></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}