import Foundation
let pattern = #"http\S*?(?:accounts?+|tech|customers?+|supports?+|services?+|phones?+|helps?+)[\w-]{0,10}(?:services?+|cares?+|helps?+|recover(?:y|ies)?+|supports?+|phones?+|numbers?+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"<a href="https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers" rel="nofollow noreferrer">https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers</a></p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)