const regex = /http\S*?(?:accounts?+|tech|customers?+|supports?+|services?+|phones?+|helps?+)[\w-]{0,10}(?:services?+|cares?+|helps?+|recover(?:y|ies)?+|supports?+|phones?+|numbers?+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http\\S*?(?:accounts?+|tech|customers?+|supports?+|services?+|phones?+|helps?+)[\\w-]{0,10}(?:services?+|cares?+|helps?+|recover(?:y|ies)?+|supports?+|phones?+|numbers?+)', 'gmi')
const str = `<a href="https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers" rel="nofollow noreferrer">https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers</a></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}