using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http\S*?(?:accounts?+|tech|customers?+|supports?+|services?+|phones?+|helps?+)[\w-]{0,10}(?:services?+|cares?+|helps?+|recover(?:y|ies)?+|supports?+|phones?+|numbers?+)";
string input = @"<a href=""https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers"" rel=""nofollow noreferrer"">https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers</a></p>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}