import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http\\S*?(?:accounts?+|tech|customers?+|supports?+|services?+|phones?+|helps?+)[\\w-]{0,10}(?:services?+|cares?+|helps?+|recover(?:y|ies)?+|supports?+|phones?+|numbers?+)";
final String string = "<a href=\"https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers\" rel=\"nofollow noreferrer\">https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers</a></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}