// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?) +(\(.*?\)).*?(\(.*?\))").unwrap();
let string = "3D Combat Zone (1983)(Aackosoft)(NL)(en)[re-release]
";
let substitution = "$1\\r\\n$2\\r\\n$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}