import Foundation
let pattern = #"^(.*?) +(\(.*?\)).*?(\(.*?\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3D Combat Zone (1983)(Aackosoft)(NL)(en)[re-release]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\r\n$2\r\n$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)