package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(?:(?:ide|sata|ssd|floppy\sdisk),)+(?:ide|sata|ssd|floppy\sdisk)$`)
var str = `sata,floppy disk
IDE,SSD
SATA,ide,SSD
ssd,Floppy Disk
hard drive,floppy disk
IDE,USB stick`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}