// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(?:(?:ide|sata|ssd|floppy\sdisk),)+(?:ide|sata|ssd|floppy\sdisk)$").unwrap();
let string = "sata,floppy disk
IDE,SSD
SATA,ide,SSD
ssd,Floppy Disk
hard drive,floppy disk
IDE,USB stick";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}