re = /^(?:(?:ide|sata|ssd|floppy\sdisk),)+(?:ide|sata|ssd|floppy\sdisk)$/im
str = 'sata,floppy disk
IDE,SSD
SATA,ide,SSD
ssd,Floppy Disk
hard drive,floppy disk
IDE,USB stick'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end