const regex = new RegExp('^(?:(?:ide|sata|ssd|floppy\\sdisk),)+(?:ide|sata|ssd|floppy\\sdisk)$', 'igm')
const str = `sata,floppy disk
IDE,SSD
SATA,ide,SSD
ssd,Floppy Disk
hard drive,floppy disk
IDE,USB stick`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}