import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:ide|sata|ssd|floppy\\sdisk),)+(?:ide|sata|ssd|floppy\\sdisk)$";
final String string = "sata,floppy disk\n"
+ "IDE,SSD\n"
+ "SATA,ide,SSD\n"
+ "ssd,Floppy Disk\n"
+ "hard drive,floppy disk\n"
+ "IDE,USB stick";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}