$re = '/^(?:(?:ide|sata|ssd|floppy\sdisk),)+(?:ide|sata|ssd|floppy\sdisk)$/im';
$str = 'sata,floppy disk
IDE,SSD
SATA,ide,SSD
ssd,Floppy Disk
hard drive,floppy disk
IDE,USB stick';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);