#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^([A-Z|a-z|0-9]{4},)*[A-Z|a-z|0-9]{4}$"
Local $sString = "COM1,COM2,COM3,1234" & @CRLF & _
"COM,1234,COM,1234" & @CRLF & _
"1234,1234,34F" & @CRLF & _
"1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")