use strict;
my $str = 'COM1,COM2,COM3,1234
COM,1234,COM,1234
1234,1234,34F
1234';
my $regex = qr/^([A-Z|a-z|0-9]{4},)*[A-Z|a-z|0-9]{4}$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}