using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z|a-z|0-9]{4},)*[A-Z|a-z|0-9]{4}$";
string input = @"COM1,COM2,COM3,1234
COM,1234,COM,1234
1234,1234,34F
1234";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}